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6.3.1. Creating a function 
 

Excel has a variety of functions available. Here are some of the most common functions you'll use: 

 SUM: This function adds all of the values of the cells in the argument. 

 AVERAGE: This function determines the average of the values included in the argument. It 

calculates the sum of the cells and then divides that value by the number of cells in the argument. 

 COUNT: This function counts the number of cells with numerical data in the argument. This 

function is useful for quickly counting items in a cell range. 

 MAX: This function determines the highest cell value included in the argument. 

 MIN: This function determines the lowest cell value included in the argument. 

 

To create a basic function 

In our example below, we'll create a basic function to calculate the average price per unit for a list of 

recently ordered items using the AVERAGE function. 

1. Select the cell that will contain the function. 

2. Type the equals sign (=) and enter the desired function name. You can also select the desired 

function from the list of suggested functions that will appear below the cell as you type. In our 

example, we'll type =AVERAGE. 
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3. Enter the cell range for the argument inside parentheses. In our example, we'll type (D3:D12). 

4. Press Enter on your keyboard. The function will be calculated, and the result will appear in the cell. 

 

To create a function using the AutoSum command 

The AutoSum command allows you to automatically insert the most common functions into your formula, 

including SUM, AVERAGE, COUNT, MIN, and MAX. In our example below, we'll create a function to 

calculate the total cost for a list of recently ordered items using the SUM function. 

1. Select the cell that will contain the function.  

2. In the Editing group on the Home tab, locate and select the arrow next to the AutoSum command 

and then choose the desired function from the drop-down menu. In our example, we'll select Sum. 
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3. The selected function will appear in the cell. If logically placed, the AutoSum command will 

automatically select a cell range for the argument. You can also manually enter the desired cell 

range into the argument. 

 

 

 

 

 

 

 

 

 

4. Press Enter on your keyboard.  

 

6.3.2. The Function Library 

 

While there are hundreds of functions in Excel, the ones you use most frequently will depend on the type 

of data your workbooks contains. There is no need to learn every single function, but exploring some of 

the different types of functions will be helpful as you create new projects. You can search for functions by 

category, such as Financial, Logical, Text, Date & Time, and more from the Function Library on the Formulas 

tab. 

 To access the Function Library, select the Formulas tab on the Ribbon. The Function Library will 

appear.  
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 If you're having trouble finding the right function, the Insert Function command allows you to 

search for functions using keywords. 

 The AutoSum command allows you to automatically return results for common functions, like 

SUM, AVERAGE, and COUNT. 

 The Recently Used command gives you access to functions that you have recently worked with. 

 The Financial category contains functions for financial calculations like determining a payment (PMT) or 

interest rate for a loan (RATE). 

 Functions in the Logical category check arguments for a value or condition. For example, if an order is over 

$50 add $4.99 for shipping, but if it is over $100, do not charge for shipping (IF). 

 The Text category contains functions that work with the text in arguments to perform tasks, such as 

converting text to lowercase (LOWER) or replacing text (REPLACE). 

 The Date & Time category contains functions for working with dates and time and will return results like 

the current date and time (NOW) or the seconds (SECOND). 

 The Lookup & Reference category contains functions that will return results for finding and referencing 

information. For example, you can add a hyperlink (HYPERLINK) to a cell or return the value of a particular 

row and column intersection (INDEX). 

 The Math & Trig category includes functions for numerical arguments. For example, you can round values 

(ROUND), find the value of Pi (PI) multiply (PRODUCT), subtotal (SUBTOTAL), and much more. 

 More Functions contains additional functions under categories for Statistical, Engineering, Cube, 

Information, and Compatibility. 

To insert a function from the Function Library 

1. Select the cell that will contain the function. 

2. Click the Formulas tab on the Ribbon to access the Function Library.  

3. From the Function Library group, select the desired function category. 

4. Select the desired function from the drop-down menu. 
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5. The Function Arguments dialog box will appear. From here, you'll be able to enter or select the 

cells that will make up the arguments in the function. 

 

 

 

 

 

 

 

6. When you're satisfied with the arguments, click OK. 

7. The function will be calculated, and the result will appear in the cell. 
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Like formulas, functions can be copied to adjacent cells. Hover the mouse over the cell that contains the 
function, then click, hold, and drag the fill handle over the cells you wish to fill. The function will be copied, 
and values for those cells will be calculated relative to their rows or columns. 

 

 

 

 

 

 

 

 

 

 

6.3.3. The Insert Function command 

 

If you're having trouble finding the right function, the Insert Function command allows you to search for 

functions using keywords. While it can be extremely useful, this command is sometimes a little difficult to 

use. If you don't have much experience with functions, you may have more success browsing the Function 

Library instead. For more advanced users, however, the Insert Function command can be a powerful way 

to find a function quickly. 

 

To use the Insert Function command 

1. Select the cell that will contain the function. 

2. Click the Formulas tab on the Ribbon, then select the Insert Function command. 

3. The Insert Function dialog box will appear. 

4. Type a few keywords describing the calculation you want the function to perform, then click Go. 

5. Review the results to find the desired function, then click OK. 
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6. The Function Arguments dialog box will appear. 

7. When you're satisfied, click OK. 

8. The function will be calculated, and the result will appear in the cell. 

 

Challenge! 

1. Open an existing Excel workbook.  

2. Create a function that contains one argument. If you're using the example, use the SUM function 

in cell B16 to calculate the total quantity of items ordered. 

3. Use the AutoSum command to insert a function.  

4. Explore the Function Library, and try using the Insert Function command to search for different 

types of functions. 
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Excel Formulas You Should Definitely Know 

1. SUM 

Formula: =SUM(5, 5) or =SUM(A1, B1) or =SUM(A1:B5) 

The SUM formula does exactly what you would expect. It allows you to add 2 or more numbers together. 

You can use cell references as well in this formula. 

 

2. COUNT 

Formula: =COUNT(A1:A10) 

The count formula counts the number of cells in a range that have numbers in them. 

 

It only counts the cells where there are numbers. 

 

3. COUNTA 

Formula: =COUNTA(A1:A10) 

Counts the number of non-empty cells in a range. It will count cells that have numbers and/or any other 

characters in them. 

The COUNTA Formula works with all data types. 
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It counts the number of non-empty cells no matter the data type. 

4. LEN 

Formula: =LEN(A1) 

The LEN formula counts the number of characters in a cell. This includes spaces! 

 

Notice the difference in the formula results: 10 characters without spaces in between the words, 12 with 

spaces between the words. 

5. VLOOKUP 

Formula: =VLOOKUP(lookup_value, table_array, col_index_num, range_lookup) 

Basically, VLOOKUP lets you search for specific information in your spreadsheet. For example, if you have 

a list of products with prices, you could search for the price of a specific item. 

We’re going to use VLOOKUP to find the price of the Photo frame. You can probably already see that the 

price is $9.99, but that’s because this is a simple example. Once you learn how to use VLOOKUP, you’ll be 

able to use it with larger, more complex spreadsheets, and that’s when it will become truly useful. 
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As with any formula, you’ll start with an equal sign (=). Then, type the formula name. 

=VLOOKUP(“Photo frame” 

The second argument is the cell range that contains the data. In this example, our data is in A2:B16. As 

with any function, you’ll need to use a comma to separate each argument: 

=VLOOKUP(“Photo frame”, A2:B16 

Note: It’s important to know that VLOOKUP will always search the first column in this range. In this 

example, it will search column A for “Photo frame”. In some cases, you may need to move the columns 

around so that the first column contains the correct data. 

The third argument is the column index number. It’s simpler than it sounds: The first column in the range 

is 1, the second column is 2, etc. In this case, we are trying to find the price of the item, and the prices are 

contained in the second column. That means our third argument will be 2: 

=VLOOKUP(“Photo frame”, A2:B16, 2 

The fourth argument tells VLOOKUP whether to look for approximate matches, and it can be either TRUE 

or FALSE. If it is TRUE, it will look for approximate matches. Generally, this is only useful if the first column 

has numerical values that have been sorted. Since we’re only looking for exact matches, the fourth 

argument should be FALSE. This is our last argument, so go ahead and close the parentheses: 

=VLOOKUP(“Photo frame”, A2:B16, 2, FALSE) 

And that’s it! When you press enter, it should give you the answer, which is 9.99. 
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6. IF Statements 

Formula: =IF(logical_statement, return this if logical statement is true, return this if logical statement is 

false). 

Example 

Let’s say a salesperson has a quota to meet. You used VLOOKUP to put the revenue next to the name. Now you can 

use an IF statement that says: “IF the salesperson met their quota, say “Met quota”, if not say “Did not meet quota” 

=IF(C3>D3, “Met Quota”, “Did Not Meet Quota”) 

This IF statement will tell us if the first salesperson met their quota or not. We would then copy and paste 

this formula along all the entries in the list. It would change for each sales person. 
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7. Working with Data 

Whenever you're working with a lot of data, it can be difficult to compare information in your workbook. 

7.1 Freezing Panes and View Options 
 

Excel includes several tools that make it easier to view content from different parts of your workbook at 

the same time, such as the ability to freeze panes and split your worksheet. 

To freeze rows 

You may want to see certain rows or columns all the time in your worksheet, especially header cells. By 

freezing rows or columns in place, you'll be able to scroll through your content while continuing to view 

the frozen cells. 

1. Select the row below the row(s) you wish to freeze. 

2. Click the View tab on the Ribbon.  

3. Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

 

 

 

 

 

 

 

 

 

 

 

The rows will be frozen in place, as indicated by the gray line. You can scroll down the worksheet while 

continuing to view the frozen rows at the top. 

To freeze columns 

1. Select the column to the right of the column(s) you wish to freeze. 
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2. Click the View tab on the Ribbon. 

3. Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

4. The column will be frozen in place, as indicated by the gray line. You can scroll across the 

worksheet while continuing to view the frozen column on the left. 

To unfreeze rows or columns, click the Freeze Panes command, then select Unfreeze Panes from the 

drop-down menu. 

 

To split a worksheet 

Sometimes you may want to compare different sections of the same workbook without creating a new 

window. The Split command allows you to divide the worksheet into multiple panes that scroll 

separately. 

1. Select the cell where you wish to split the worksheet. 

2. Click the View tab on the Ribbon, then select the Split command.  

 

3. The workbook will be split into different panes. You can scroll through each pane separately 

using the scroll bars, allowing you to compare different sections of the workbook. 

To remove the split, click the Split command again. 

 

Challenge! 

1. Open an existing Excel workbook.  

2. Try freezing a row or column in place.  

3. Use the Split command to split your worksheet into multiple panes. 

 

7.2 Sorting Data 
 

As you add more content to a worksheet, organizing that information becomes especially important. You 

can quickly reorganize a worksheet by sorting your data. For example, you could organize a list of contact 

information by last name. Content can be sorted alphabetically, numerically, and in many other ways. 
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When sorting data, it's important to first decide if you would like the sort to apply to the entire worksheet 

or just a cell range.  

 Sort sheet organizes all of the data in your worksheet by one column.  

 Sort range sorts the data in a range of cells, which can be helpful when working with a sheet that 

contains several tables. Sorting a range will not affect other content on the worksheet. 

 

To sort a sheet 

In our example, we'll sort a T-shirt order form alphabetically by Last Name (column C). 

1. Select a cell in the column you wish to sort by. In our example, we'll select cell C2.  

 

 

2. Select the Data tab on the Ribbon, then click the Ascending command  to Sort A to Z, or the 

Descending command  to Sort Z to A. In our example, we'll click the Ascending command.  

 

 

3. The worksheet will be sorted by the selected column. In our example, the worksheet is now sorted 

by last name. 
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7.3 Filtering Data 

 

If your worksheet contains a lot of content, it can be difficult to find information quickly. Filters can be 

used to narrow down the data in your worksheet, allowing you to view only the information you need. 

To filter data 

1. In order for filtering to work correctly, your worksheet should include a header row, which is used 

to identify the name of each column. 

2. Select the Data tab, then click the Filter command.  

 

 

 

 

 

 

 

 

 

 

3. A drop-down arrow will appear in the header cell for each column.  

4. Click the drop-down arrow for the column you wish to filter. 
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5. The Filter menu will appear.  

6. Uncheck the box next to Select All to quickly deselect all data. 

7. Check the boxes next to the data you wish to filter, then click OK. 

To remove all filters from your worksheet, click the Filter command on the Data tab. 

 

8. Working with Charts 

Creating a chart in Microsoft Office Excel is quick and easy. Excel provides a variety of chart types that you 

can choose from when you create a chart. Excel offers Pie, Line, Bar, and Column charts to name but a 

few. Showing data in a chart can make it clearer, more interesting and easier to read. Charts can also help 

you evaluate your data and make comparisons between different values. 

 

8.1. Understanding charts 
 

Excel has several different types of charts, allowing you to choose the one that best fits your data. In order 

to use charts effectively, you'll need to understand how different charts are used. 

Types of Charts: 

 Column charts use vertical bars to represent data. They can work with many different types of 

data, but they're most frequently used for comparing information. 

 Line charts are ideal for showing trends. The data points are connected with lines, making it easy 

to see whether values are increasing or decreasing over time. 

 Pie charts make it easy to compare proportions. Each value is shown as a slice of the pie, so it's 

easy to see which values make up the percentage of a whole. 

 Bar charts work just like Column charts, but they use horizontal bars instead of vertical bars. 

 Area charts are similar to line charts, except that the areas under the lines are filled in. 

 Surface charts allow you to display data across a 3D landscape. They work best with large data sets, 

allowing you to see a variety of information at the same time. 

 

To insert a chart 

 

1. Select the cells you want to chart, including the column titles and row labels. These cells will be 

the source data for the chart.  
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2. From the Insert tab, click the desired Chart command.  

3. Choose the desired chart type from the drop-down menu. 

 

 

 

 

 

 

 

 

 

4. The selected chart will be inserted in the worksheet. 

 TIP:  If you're not sure which type of chart to use, the Recommended Charts command will 

suggest several different charts based on the source data.  

 

 
 

8.2. Chart layout and style 
 

After inserting a chart, there are several things you may want to change about the way your data is 

displayed. It's easy to edit a chart's layout and style from the Design tab. 

 Excel allows you to add chart elements—such as chart titles, legends, and data labels—to make 

your chart easier to read. To add a chart element, click the Add Chart Element command on the 

Design tab, then choose the desired element from the drop-down menu.  
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 To edit a chart element, like a chart title, simply double-click the placeholder and begin typing.  

 

 

 

 

 

 

 

 

 

 

 If you don't want to add chart elements individually, you can use one of Excel's predefined layouts. 

Simply click the Quick Layout command, then choose the desired layout from the drop-down 

menu. 

 Excel also includes several different chart styles, which allow you to quickly modify the look and 

feel of your chart. To change the chart style, select the desired style from the Chart styles group. 
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 TIP: You can also use the chart formatting shortcut buttons to quickly add chart elements, change 

the chart style, and filter the chart data. 

 

 

 

 

 

 

 

 

 

 

 

 

8.3. Other chart options 
 

There are lots of other ways to customize and organize your charts. For example, Excel allows you to 

rearrange a chart's data, change the chart type, and even move the chart to a different location in the 

workbook. 

To switch row and column data 

Sometimes you may want to change the way charts group your data. For example, in the chart below, the 

Book Sales data are grouped by year, with columns for each genre. However, we could switch the rows 

and columns so the chart will group the data by genre, with columns for each year. In both cases, the chart 

contains the same data—it's just organized differently. 

1. Select the chart you wish to modify. 
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2. From the Design tab, select the Switch Row/Column command.  

 

3. The rows and columns will be switched.  

 

To change the chart type 

If you find that your data isn't well suited to a certain chart, it's easy to switch to a new chart type. In our 

example, we'll change our chart from a Column chart to a Line chart. 

1. From the Design tab, click the Change Chart Type command.  

 

2. The Change Chart Type dialog box will appear.  

3. The selected chart type will appear.  

 

To move a chart 

Whenever you insert a new chart, it will appear as an object on the same worksheet that contains its 

source data. Alternatively, you can move the chart to a new worksheet to help keep your data organized. 

1. Select the chart you wish to move. 

2. Click the Design tab, then select the Move Chart command.  
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3. The Move Chart dialog box will appear. Select the desired location for the chart.  

4. Click OK.  

5. The chart will appear in the selected location.  

 

Challenge! 

1. Open an existing Excel workbook.  

2. Use worksheet data to create a chart.  

3. Change the chart layout.  

4. Apply a chart style. 

5. Move the chart.  

 

9. Printing Workbooks 

There may be times when you want to print a workbook to view and share your data offline. Once you've 

chosen your page layout settings, it's easy to preview and print a workbook from Excel using the Print 

pane. 

 

To access the Print pane 

1. Select the File tab. Backstage view will appear. 

 

 

 

2. Select Print. The Print pane will appear. 
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9.1. Choosing a print area 
 

Before you print an Excel workbook, it's important to decide exactly what information you want to print. 

For example, if you have multiple worksheets in your workbook, you will need to decide if you want to 

print the entire workbook or only active worksheets. There may also be times when you want to print only 

a selection of content from your workbook. 

When you are ready to 
print the workbook, 
click the Print button. 

Here you can choose how 
many copies of the 

workbook you wish to print. 

You may need to select the printer 
you want to use if your computer is 

connected to multiple printers. 

Here you can choose to print 

the active sheets, the entire 

workbook, or a selection of 

cells. 

Here you can choose 
whether to print on one side 
or both sides of the paper. If you are printing multiple copies, 

you can choose whether you want 

the copies collated or uncollated. 

Here you can choose Portrait 

or Landscape orientation. 
If your printer uses different 

paper sizes, you can choose the 

paper size you wish to use. 

Here you can adjust the 
page margins, which can 

help your data fit more 
comfortably on the page. 

Here you can choose how to scale your 
worksheets for the printed page. You can 

scale worksheets at their actual size, fit the 
entire worksheet on one page, fit all columns 

on one page, or fit all rows on one page. 
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To print active sheets 

Worksheets are considered active when selected. 

1. Select the worksheet you want to print. To print multiple worksheets, click the first worksheet, hold 

the Ctrl key on your keyboard, then click any other worksheets you want to select.  

 

2. Navigate to the Print pane. 

3. Select Print Active Sheets from the Print Range drop-down menu.  

 

4. Click the Print button.  

 

 

 

To print the entire workbook 

1. Navigate to the Print pane. 

2. Select Print Entire Workbook from the Print Range drop-down menu.  
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3. Click the Print button.  

 

 

To print a selection 

1. Select the cells you wish to print.  

2. Navigate to the Print pane. 

3. Select Print Selection from the Print Range drop-down menu.  

 

4. A preview of your selection will appear in the Preview pane.  

5. Click the Print button to print the selection.  
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 TIP: If you prefer, you can also set the print area in advance so you'll be able to visualize which cells 

will be printed as you work in Excel. Simply select the cells you want to print, click the Page Layout 

tab, select the Print Area command, then choose Set Print Area. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

9.2. Fitting and scaling content 
 

On occasion, you may need to make small adjustments from the Print pane to fit your workbook content 

neatly onto a printed page. The Print pane includes several tools to help fit and scale your content, such 

as scaling and page margins. 
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To fit content before printing 

If some of your content is being cut off by the printer, you can use scaling to fit your workbook to the page 

automatically. 

1. Navigate to the Print pane.  

2. Select the desired option from the Scaling drop-down menu. In our example, we'll select Fit Sheet 

on One Page.  

 

3. The worksheet will be condensed to fit onto a single page. 

4. When you're satisfied with the scaling, click Print.  

 

To modify margins in the Preview pane 

Sometimes you may only need to adjust a single margin to make your data fit more comfortably. You can 

modify individual page margins from the Preview pane. 

1. Navigate to the Print pane, then click the Show Margins button in the lower-right corner. 
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2. The page margins will appear in the Preview pane. Hover the mouse over one of the margin 

markers until the cursor becomes a double arrow .  

3. Click, hold, and drag the mouse to increase or decrease the margin width.  

4. Release the mouse. The margin will be modified. In our example, we were able to fit an additional 

column on the page. 

 

Challenge! 

1. Open an existing Excel workbook.  

2. Try printing two active worksheets.  

3. Try printing only a selection of cells.  

4. Try the scaling feature to condense your workbook content.  

5. Adjust the margins from the Preview pane. 

Show Margins 

button. 


